CVE-2021-20308

NameCVE-2021-20308
DescriptionInteger overflow in the htmldoc 1.9.11 and before may allow attackers to execute arbitrary code and cause a denial of service that is similar to CVE-2017-9181.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
htmldoc (PTS)stretch1.8.27-8vulnerable
buster1.9.3-1vulnerable
bullseye, sid1.9.11-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
htmldocsource(unstable)(unfixed)unimportant

Notes

https://github.com/michaelrsweet/htmldoc/issues/423
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems