CVE-2021-20314

NameCVE-2021-20314
DescriptionStack buffer overflow in libspf2 versions below 1.2.11 when processing certain SPF macros can lead to Denial of service and potentially code execution via malicious crafted SPF explanation messages.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2739-1, DSA-4955-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libspf2 (PTS)stretch1.2.10-7vulnerable
stretch (security)1.2.10-7+deb9u1fixed
buster, buster (security)1.2.10-7.1~deb10u1fixed
bullseye (security), bullseye1.2.10-7.1~deb11u1fixed
bookworm, sid1.2.10-7.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libspf2sourcestretch1.2.10-7+deb9u1DLA-2739-1
libspf2sourcebuster1.2.10-7.1~deb10u1DSA-4955-1
libspf2sourcebullseye1.2.10-7.1~deb11u1
libspf2source(unstable)1.2.10-7.1

Notes

https://github.com/shevek/libspf2/commit/c37b7c13c30e225183899364b9f2efdfa85552ef
https://www.openwall.com/lists/oss-security/2021/08/11/6

Search for package or bug name: Reporting problems