CVE-2021-21290

NameCVE-2021-21290
DescriptionNetty is an open-source, asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In Netty before version 4.1.59.Final there is a vulnerability on Unix-like systems involving an insecure temp file. When netty's multipart decoders are used local information disclosure can occur via the local system temporary directory if temporary storing uploads on the disk is enabled. On unix-like systems, the temporary directory is shared between all user. As such, writing to this directory using APIs that do not explicitly set the file/directory permissions can lead to information disclosure. Of note, this does not impact modern MacOS Operating Systems. The method "File.createTempFile" on unix-like systems creates a random file, but, by default will create this file with the permissions "-rw-r--r--". Thus, if sensitive information is written to this file, other local users can read this information. This is the case in netty's "AbstractDiskHttpData" is vulnerable. This has been fixed in version 4.1.59.Final. As a workaround, one may specify your own "java.io.tmpdir" when you start the JVM or use "DefaultHttpDataFactory.setBaseDir(...)" to set the directory to something that is only readable by the current user.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2555-1, DSA-4885-1
NVD severitylow
Debian Bugs982580

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
netty (PTS)stretch1:4.1.7-2+deb9u1vulnerable
stretch (security)1:4.1.7-2+deb9u3fixed
buster1:4.1.33-1+deb10u1vulnerable
buster (security)1:4.1.33-1+deb10u2fixed
bullseye, sid1:4.1.48-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nettysourcestretch1:4.1.7-2+deb9u3DLA-2555-1
nettysourcebuster1:4.1.33-1+deb10u2DSA-4885-1
nettysource(unstable)1:4.1.48-2982580

Notes

https://github.com/netty/netty/security/advisories/GHSA-5mcr-gq6c-3hq2
https://github.com/netty/netty/commit/c735357bf29d07856ad171c6611a2e1a0e0000ec

Search for package or bug name: Reporting problems