CVE-2021-21311

NameCVE-2021-21311
DescriptionAdminer is an open-source database management in a single PHP file. In adminer from version 4.0.0 and before 4.7.9 there is a server-side request forgery vulnerability. Users of Adminer versions bundling all drivers (e.g. `adminer.php`) are affected. This is fixed in version 4.7.9.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2580-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
adminer (PTS)stretch4.2.5-3+deb9u1vulnerable
stretch (security)4.2.5-3+deb9u2fixed
buster4.7.1-1vulnerable
bullseye4.7.9-2fixed
bookworm, sid4.8.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
adminersourcestretch4.2.5-3+deb9u2DLA-2580-1
adminersource(unstable)4.7.9-1

Notes

[buster] - adminer <no-dsa> (Minor issue)
https://github.com/vrana/adminer/security/advisories/GHSA-x5r2-hj5c-8jx6
https://github.com/vrana/adminer/commit/ccd2374b0b12bd547417bf0dacdf153826c83351 (v4.7.9)

Search for package or bug name: Reporting problems