CVE-2021-21375

NameCVE-2021-21375
DescriptionPJSIP is a free and open source multimedia communication library written in C language implementing standard based protocols such as SIP, SDP, RTP, STUN, TURN, and ICE. In PJSIP version 2.10 and earlier, after an initial INVITE has been sent, when two 183 responses are received, with the first one causing negotiation failure, a crash will occur. This results in a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs986815

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pjproject (PTS)stretch (security), stretch2.5.5~dfsg-6+deb9u1vulnerable
ring (PTS)stretch20161221.2.7bd7d91~dfsg1-1vulnerable
buster20190215.1.f152c98~ds1-1vulnerable
bullseye, sid20210104.4.dda80df~ds1-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pjprojectsource(unstable)(unfixed)
ringsource(unstable)(unfixed)986815

Notes

https://github.com/pjsip/pjproject/security/advisories/GHSA-hvq6-f89p-frvp
https://github.com/pjsip/pjproject/commit/97b3d7addbaa720b7ddb0af9bf6f3e443e664365

Search for package or bug name: Reporting problems