CVE-2021-21702

NameCVE-2021-21702
DescriptionIn PHP versions 7.3.x below 7.3.27, 7.4.x below 7.4.15 and 8.0.x below 8.0.2, when using SOAP extension to connect to a SOAP server, a malicious SOAP server could return malformed XML data as a response that would cause PHP to access a null pointer and thus cause a crash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2708-1, DSA-4856-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php7.0 (PTS)stretch7.0.33-0+deb9u8vulnerable
stretch (security)7.0.33-0+deb9u11fixed
php7.3 (PTS)buster7.3.29-1~deb10u1fixed
buster (security)7.3.31-1~deb10u1fixed
php7.4 (PTS)bullseye (security)7.4.25-1+deb11u1fixed
bookworm, bullseye, sid7.4.21-1+deb11u1fixed
php8.0 (PTS)sid8.0.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php7.0sourcestretch7.0.33-0+deb9u11DLA-2708-1
php7.0source(unstable)(unfixed)
php7.3sourcebuster7.3.27-1~deb10u1DSA-4856-1
php7.3source(unstable)(unfixed)
php7.4source(unstable)7.4.15-1
php8.0source(unstable)8.0.2-1

Notes

Fixed in PHP 8.0.2, 7.4.15, 7.3.27
PHP Bug: https://bugs.php.net/80672

Search for package or bug name: Reporting problems