CVE-2021-21706

NameCVE-2021-21706
DescriptionIn PHP versions 7.3.x below 7.3.31, 7.4.x below 7.4.24 and 8.0.x below 8.0.11, in Microsoft Windows environment, ZipArchive::extractTo may be tricked into writing a file outside target directory when extracting a ZIP file, thus potentially causing files to be created or overwritten, subject to OS permissions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php7.0 (PTS)stretch7.0.33-0+deb9u8fixed
stretch (security)7.0.33-0+deb9u12fixed
php7.3 (PTS)buster7.3.29-1~deb10u1fixed
buster (security)7.3.31-1~deb10u1fixed
php7.4 (PTS)bullseye (security)7.4.25-1+deb11u1fixed
bookworm, sid, bullseye7.4.21-1+deb11u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php7.0source(unstable)(not affected)
php7.3source(unstable)(not affected)
php7.4source(unstable)(not affected)
php8.0source(unstable)(not affected)

Notes

- php8.0 <not-affected> (Windows specific issue)
- php7.4 <not-affected> (Windows specific issue)
- php7.3 <not-affected> (Windows specific issue)
- php7.0 <not-affected> (Windows specific issue)
Fixed in 8.0.11, 7.4.24, 7.3.31
PHP Bug: https://bugs.php.net/81420

Search for package or bug name: Reporting problems