CVE-2021-22883

NameCVE-2021-22883
DescriptionNode.js before 10.24.0, 12.21.0, 14.16.0, and 15.10.0 is vulnerable to a denial of service attack when too many connection attempts with an 'unknownProtocol' are established. This leads to a leak of file descriptors. If a file descriptor limit is configured on the system, then the server is unable to accept new connections and prevent the process also from opening, e.g. a file. If no file descriptor limit is configured, then this lead to an excessive memory usage and cause the system to run out of memory.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4863-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nodejs (PTS)stretch4.8.2~dfsg-1vulnerable
buster, buster (security)10.24.0~dfsg-1~deb10u1fixed
bullseye, sid12.21.0~dfsg-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nodejssourcebuster10.24.0~dfsg-1~deb10u1DSA-4863-1
nodejssource(unstable)12.21.0~dfsg-1

Notes

[stretch] - nodejs <ignored> (Nodejs in stretch not covered by security support)
https://nodejs.org/en/blog/vulnerability/february-2021-security-releases/

Search for package or bug name: Reporting problems