CVE-2021-23368

NameCVE-2021-23368
DescriptionThe package postcss from 7.0.0 and before 8.2.10 are vulnerable to Regular Expression Denial of Service (ReDoS) during source map parsing.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-postcss (PTS)buster6.0.23-1fixed
bullseye, sid8.2.1+~cs5.3.23-8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-postcsssourcebuster(not affected)
node-postcsssource(unstable)8.2.1+~cs5.3.23-6

Notes

[buster] - node-postcss <not-affected> (Vulnerable code not present)
https://github.com/postcss/postcss/commit/8682b1e4e328432ba692bed52326e84439cec9e4
https://github.com/postcss/postcss/commit/b6f3e4d5a8d7504d553267f80384373af3a3dec5
https://snyk.io/vuln/SNYK-JS-POSTCSS-1090595

Search for package or bug name: Reporting problems