CVE-2021-23382

NameCVE-2021-23382
DescriptionThe package postcss before 8.2.13 are vulnerable to Regular Expression Denial of Service (ReDoS) via getAnnotationURL() and loadAnnotation() in lib/previous-map.js. The vulnerable regexes are caused mainly by the sub-pattern \/\*\s* sourceMappingURL=(.*).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-postcss (PTS)buster6.0.23-1vulnerable
bullseye, sid8.2.1+~cs5.3.23-8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-postcsssource(unstable)8.2.1+~cs5.3.23-7

Notes

[buster] - node-postcss <no-dsa> (Minor issue)
https://snyk.io/vuln/SNYK-JS-POSTCSS-1255640
https://github.com/postcss/postcss/commit/2ad1ca9b965dde32223bee28dc259c339cbaaa05 (8.2.13)

Search for package or bug name: Reporting problems