CVE-2021-23385

NameCVE-2021-23385
DescriptionThis affects all versions of package Flask-Security. When using the get_post_logout_redirect and get_post_login_redirect functions, it is possible to bypass URL validation and redirect a user to an arbitrary URL by providing multiple back slashes such as \\\evil.com/path. This vulnerability is only exploitable if an alternative WSGI server other than Werkzeug is used, or the default behaviour of Werkzeug is modified using 'autocorrect_location_header=False. **Note:** Flask-Security is not maintained anymore.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3545-1
Debian Bugs1021279

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
flask-security (PTS)buster1.7.5-2vulnerable
buster (security)1.7.5-2+deb10u1fixed
bullseye4.0.0-1+deb11u1fixed
bookworm5.1.2-1fixed
sid, trixie5.3.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
flask-securitysourcebuster1.7.5-2+deb10u1DLA-3545-1
flask-securitysourcebullseye4.0.0-1+deb11u1
flask-securitysource(unstable)5.0.2-11021279

Notes

https://security.snyk.io/vuln/SNYK-PYTHON-FLASKSECURITY-1293234
https://github.com/Flask-Middleware/flask-security/issues/724
https://github.com/Flask-Middleware/flask-security/issues/486
https://github.com/Flask-Middleware/flask-security/security/advisories/GHSA-6qmf-fj6m-686c
https://github.com/Flask-Middleware/flask-security/commit/e39bb04615050448c1b8ba4caa7dacc0edd3e405 (4.1.0)

Search for package or bug name: Reporting problems