CVE-2021-23418

NameCVE-2021-23418
DescriptionThe package glances before 3.2.1 are vulnerable to XML External Entity (XXE) Injection via the use of Fault to parse untrusted XML data, which is known to be vulnerable to XML attacks.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
glances (PTS)stretch2.7.1.1-2vulnerable
buster3.1.0-1+deb10u1vulnerable
sid3.1.5-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
glancessource(unstable)(unfixed)

Notes

[bullseye] - glances <no-dsa> (Minor issue)
[buster] - glances <no-dsa> (Minor issue)
[stretch] - glances <no-dsa> (Minor issue)
https://github.com/nicolargo/glances/issues/1025
https://github.com/nicolargo/glances/commit/4b87e979afdc06d98ed1b48da31e69eaa3a9fb94
https://github.com/nicolargo/glances/commit/85d5a6b4af31fcf785d5a61086cbbd166b40b07a
https://github.com/nicolargo/glances/commit/9d6051be4a42f692392049fdbfc85d5dfa458b32

Search for package or bug name: Reporting problems