CVE-2021-23440

NameCVE-2021-23440
DescriptionThis affects the package set-value before 4.0.1. A type confusion vulnerability can lead to a bypass of CVE-2019-10747 when the user-provided keys used in the path parameter are arrays.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs994448

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-set-value (PTS)stretch0.4.0-1vulnerable
buster0.4.0-1+deb10u1vulnerable
bullseye3.0.1-2vulnerable
bookworm, sid3.0.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-set-valuesource(unstable)3.0.1-3994448

Notes

[bullseye] - node-set-value <no-dsa> (Minor issue)
[buster] - node-set-value <no-dsa> (Minor issue)
[stretch] - node-set-value <no-dsa> (Minor issue)
https://github.com/jonschlinkert/set-value/commit/7cf8073bb06bf0c15e08475f9f952823b4576452 (v4.0.1)
https://github.com/jonschlinkert/set-value/pull/33/commits/383b72d47c74a55ae8b6e231da548f9280a4296a
https://github.com/jonschlinkert/set-value/pull/33

Search for package or bug name: Reporting problems