CVE-2021-23520

NameCVE-2021-23520
DescriptionThe package juce-framework/juce before 6.1.5 are vulnerable to Arbitrary File Write via Archive Extraction (Zip Slip) via the ZipFile::uncompressEntry function in juce_ZipFile.cpp. This vulnerability is triggered when the archive is extracted upon calling uncompressTo() on a ZipFile object.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
juce (PTS)buster5.4.1+really5.4.1~repack-3vulnerable
bullseye5.4.7~ds0-2vulnerable
bookworm, sid7.0.2~ds0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jucesource(unstable)6.1.5~ds0-1

Notes

[bullseye] - juce <no-dsa> (Minor issue)
[buster] - juce <no-dsa> (Minor issue)
[stretch] - juce <no-dsa> (Minor issue)
https://github.com/juce-framework/JUCE/commit/2e874e80cba0152201aff6a4d0dc407997d10a7f
https://snyk.io/vuln/SNYK-UNMANAGED-JUCEFRAMEWORKJUCE-2388607
https://snyk.io/research/zip-slip-vulnerability

Search for package or bug name: Reporting problems