DescriptionThis affects the package celery before 5.2.2. It by default trusts the messages and metadata stored in backends (result stores). When reading task metadata from the backend, the data is deserialized. Given that an attacker can gain access to, or somehow manipulate the metadata within a celery backend, they could trigger a stored command injection vulnerability and potentially gain further access to the system.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
celery (PTS)buster4.2.1-3fixed
sid, trixie5.3.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
celerysourcestretch(not affected)
celerysourcebuster(not affected)


[bullseye] - celery <no-dsa> (Minor issue)
[buster] - celery <not-affected> (Vulnerable code not present)
[stretch] - celery <not-affected> (Vulnerable code introduced later) (v5.2.3)
Introduced by: (4.4.0rc1)

Search for package or bug name: Reporting problems