CVE-2021-24031

NameCVE-2021-24031
DescriptionIn the Zstandard command-line utility prior to v1.4.1, output files were created with default permissions. Correct file permissions (matching the input) would only be set at completion time. Output files could therefore be readable or writable to unintended parties.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2573-1, DSA-4850-1
NVD severitylow
Debian Bugs981404

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libzstd (PTS)stretch1.1.2-1vulnerable
stretch (security)1.1.2-1+deb9u1fixed
buster, buster (security)1.3.8+dfsg-3+deb10u2fixed
bullseye, sid1.4.8+dfsg-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libzstdsourcestretch1.1.2-1+deb9u1DLA-2573-1
libzstdsourcebuster1.3.8+dfsg-3+deb10u1DSA-4850-1
libzstdsource(unstable)1.4.8+dfsg-1981404

Notes

https://github.com/facebook/zstd/issues/1630

Search for package or bug name: Reporting problems