CVE-2021-24032

NameCVE-2021-24032
DescriptionBeginning in v1.4.1 and prior to v1.4.9, due to an incomplete fix for CVE-2021-24031, the Zstandard command-line utility created output files with default permissions and restricted those permissions immediately afterwards. Output files could therefore momentarily be readable or writable to unintended parties.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-4859-1
Debian Bugs982519

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libzstd (PTS)buster, buster (security)1.3.8+dfsg-3+deb10u2fixed
bullseye1.4.8+dfsg-2.1fixed
bookworm1.5.4+dfsg2-5fixed
trixie1.5.5+dfsg2-2fixed
sid1.5.6+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libzstdsourcestretch(not affected)
libzstdsourcebuster1.3.8+dfsg-3+deb10u2DSA-4859-1
libzstdsource(unstable)1.4.8+dfsg-2982519

Notes

[stretch] - libzstd <not-affected> (Incomplete fix for CVE-2021-24031 not applied)
https://github.com/facebook/zstd/issues/2491

Search for package or bug name: Reporting problems