CVE-2021-25631

NameCVE-2021-25631
DescriptionIn the LibreOffice 7-1 series in versions prior to 7.1.2, and in the 7-0 series in versions prior to 7.0.5, the denylist can be circumvented by manipulating the link so it doesn't match the denylist but results in ShellExecute attempting to launch an executable type.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libreoffice (PTS)stretch (security), stretch1:5.2.7-1+deb9u11fixed
buster1:6.1.5-3+deb10u7fixed
buster (security)1:6.1.5-3+deb10u4fixed
bullseye1:7.0.4-4fixed
bullseye (security)1:7.0.4-4+deb11u1fixed
bookworm, sid1:7.2.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libreofficesource(unstable)(not affected)

Notes

- libreoffice <not-affected> (Libreoffice on Windows)
https://positive.security/blog/url-open-rce#open-libreoffice

Search for package or bug name: Reporting problems