CVE-2021-26120

NameCVE-2021-26120
DescriptionSmarty before 3.1.39 allows code injection via an unexpected function name after a {function name= substring.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2618-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
smarty3 (PTS)stretch3.1.31+20161214.1.c7d42e4+selfpack1-2+deb9u1vulnerable
stretch (security)3.1.31+20161214.1.c7d42e4+selfpack1-2+deb9u4fixed
buster3.1.33+20180830.1.3a78a21f+selfpack1-1vulnerable
bullseye3.1.39-1fixed
bookworm, sid3.1.39-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
smarty3sourcestretch3.1.31+20161214.1.c7d42e4+selfpack1-2+deb9u2DLA-2618-1
smarty3source(unstable)3.1.39-1

Notes

[buster] - smarty3 <no-dsa> (Minor issue)
https://github.com/smarty-php/smarty/commit/4f634c0097ab4a8b2adc2a97caacd1676e88f9c8

Search for package or bug name: Reporting problems