CVE-2021-26675

NameCVE-2021-26675
DescriptionA stack-based buffer overflow in dnsproxy in ConnMan before 1.39 could be used by network adjacent attackers to execute code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2552-1, DSA-4847-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
connman (PTS)stretch1.33-3+deb9u1vulnerable
stretch (security)1.33-3+deb9u2fixed
buster1.36-2.1~deb10u2fixed
buster (security)1.36-2.1~deb10u1fixed
bookworm, sid, bullseye1.36-2.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
connmansourcestretch1.33-3+deb9u2DLA-2552-1
connmansourcebuster1.36-2.1~deb10u1DSA-4847-1
connmansource(unstable)1.36-2.1

Notes

https://git.kernel.org/pub/scm/network/connman/connman.git/commit/?id=e4079a20f617a4b076af503f6e4e8b0304c9f2cb

Search for package or bug name: Reporting problems