CVE-2021-26690

NameCVE-2021-26690
DescriptionApache HTTP Server versions 2.4.0 to 2.4.46 A specially crafted Cookie header handled by mod_session can cause a NULL pointer dereference and crash, leading to a possible Denial Of Service
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2706-1, DSA-4937-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)stretch2.4.25-3+deb9u9vulnerable
stretch (security)2.4.25-3+deb9u11fixed
buster2.4.38-3+deb10u5fixed
buster (security)2.4.38-3+deb10u6fixed
bullseye2.4.48-3.1+deb11u1fixed
bullseye (security)2.4.51-1~deb11u1fixed
bookworm, sid2.4.51-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2sourceexperimental2.4.48-1
apache2sourcestretch2.4.25-3+deb9u10DLA-2706-1
apache2sourcebuster2.4.38-3+deb10u5DSA-4937-1
apache2source(unstable)2.4.46-6

Notes

https://httpd.apache.org/security/vulnerabilities_24.html#CVE-2021-26690
https://github.com/apache/httpd/commit/67bd9bfe6c38831e14fe7122f1d84391472498f8

Search for package or bug name: Reporting problems