CVE-2021-26937

NameCVE-2021-26937
Descriptionencoding.c in GNU Screen through 4.8.0 allows remote attackers to cause a denial of service (invalid write access and application crash) or possibly have unspecified other impact via a crafted UTF-8 character sequence.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2570-1, DSA-4861-1
NVD severityhigh
Debian Bugs982435

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
screen (PTS)stretch4.5.0-6vulnerable
stretch (security)4.5.0-6+deb9u1fixed
buster4.6.2-3vulnerable
buster (security)4.6.2-3+deb10u1fixed
bullseye, sid4.8.0-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
screensourcestretch4.5.0-6+deb9u1DLA-2570-1
screensourcebuster4.6.2-3+deb10u1DSA-4861-1
screensource(unstable)4.8.0-5982435

Notes

https://lists.gnu.org/archive/html/screen-devel/2021-02/msg00000.html
https://www.openwall.com/lists/oss-security/2021/02/09/3
https://savannah.gnu.org/bugs/?60030
First patch applied in -4, but revised patch applied in -5 which fixed regressions

Search for package or bug name: Reporting problems