CVE-2021-27219

NameCVE-2021-27219
DescriptionAn issue was discovered in GNOME GLib before 2.66.6 and 2.67.x before 2.67.3. The function g_bytes_new has an integer overflow on 64-bit platforms due to an implicit cast from 64 bits to 32 bits. The overflow could potentially lead to memory corruption.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs982778

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
glib2.0 (PTS)stretch2.50.3-2+deb9u2vulnerable
buster2.58.3-2+deb10u3fixed
bullseye2.66.8-1fixed
bookworm2.68.4-1fixed
sid2.70.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
glib2.0sourcebuster2.58.3-2+deb10u3
glib2.0source(unstable)2.66.6-1982778

Notes

[stretch] - glib2.0 <postponed> (requires fixing vulnerable rdeps, follow buster strategy)
https://gitlab.gnome.org/GNOME/glib/-/issues/2319
Fix introduces new API 'g_memdup2'
Fix backport in 2.66.7 adds 'g_memdup2' for internal use but does not allow fixing reverse-dependencies using vulnerable 'g_memdup'

Search for package or bug name: Reporting problems