CVE-2021-27928

NameCVE-2021-27928
DescriptionA remote code execution issue was discovered in MariaDB 10.2 before 10.2.37, 10.3 before 10.3.28, 10.4 before 10.4.18, and 10.5 before 10.5.9; Percona Server through 2021-03-03; and the wsrep patch through 2021-03-03 for MySQL. An untrusted search path leads to eval injection, in which a database SUPER user can execute OS commands after modifying wsrep_provider and wsrep_notify_cmd. NOTE: this does not affect an Oracle product.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2605-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mariadb-10.1 (PTS)stretch10.1.45-0+deb9u1vulnerable
stretch (security)10.1.48-0+deb9u2fixed
mariadb-10.3 (PTS)buster1:10.3.27-0+deb10u1vulnerable
buster (security)1:10.3.25-0+deb10u1vulnerable
mariadb-10.5 (PTS)bullseye, sid1:10.5.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mariadb-10.1sourcestretch10.1.48-0+deb9u2DLA-2605-1
mariadb-10.1source(unstable)(unfixed)
mariadb-10.3source(unstable)(unfixed)
mariadb-10.5source(unstable)1:10.5.9-1

Notes

https://jira.mariadb.org/browse/MDEV-25179
Fixed in MariaDB: 10.5.9, 10.4.18, 10.3.28, 10.2.27

Search for package or bug name: Reporting problems