CVE-2021-28543

NameCVE-2021-28543
DescriptionVarnish varnish-modules before 0.17.1 allows remote attackers to cause a denial of service (daemon restart) in some configurations. This does not affect organizations that only install the Varnish Cache product; however, it is common to install both Varnish Cache and varnish-modules. Specifically, an assertion failure or NULL pointer dereference can be triggered in Varnish Cache through the varnish-modules header.append() and header.copy() functions. For some Varnish Configuration Language (VCL) files, this gives remote clients an opportunity to cause a Varnish Cache restart. A restart reduces overall availability and performance due to an increased number of cache misses, and may cause higher load on backend servers.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs985947

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
varnish-modules (PTS)stretch0.9.1-4fixed
buster0.15.0-1fixed
bullseye, sid0.16.0-2.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
varnish-modulessourcestretch(not affected)
varnish-modulessourcebuster(not affected)
varnish-modulessource(unstable)(unfixed)985947

Notes

[buster] - varnish-modules <not-affected> (Vulnerable code not present)
[stretch] - varnish-modules <not-affected> (Vulnerable code not present)
https://varnish-cache.org/security/VSV00006.html
https://github.com/varnish/varnish-modules/commit/2c120e576ebb73bc247790184702ba58dc0afc39

Search for package or bug name: Reporting problems