CVE-2021-30851

NameCVE-2021-30851
DescriptionA memory corruption vulnerability was addressed with improved locking. This issue is fixed in Safari 15, tvOS 15, watchOS 8, iOS 15 and iPadOS 15. Processing maliciously crafted web content may lead to code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4995-1, DSA-4996-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
webkit2gtk (PTS)stretch2.18.6-1~deb9u1vulnerable
buster2.32.4-1~deb10u1vulnerable
buster (security)2.34.1-1~deb10u1fixed
bullseye2.32.4-1~deb11u1vulnerable
bullseye (security)2.34.1-1~deb11u1fixed
bookworm, sid2.34.2-1fixed
wpewebkit (PTS)bullseye2.32.4-1~deb11u1vulnerable
bullseye (security)2.34.1-1~deb11u1fixed
bookworm, sid2.34.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
webkit2gtksourcebuster2.34.1-1~deb10u1DSA-4995-1
webkit2gtksourcebullseye2.34.1-1~deb11u1DSA-4995-1
webkit2gtksource(unstable)2.34.0-1
wpewebkitsourcebullseye2.34.1-1~deb11u1DSA-4996-1
wpewebkitsource(unstable)2.34.1-1

Notes

[stretch] - webkit2gtk <ignored> (Not covered by security support in stretch)
https://webkitgtk.org/security/WSA-2021-0006.html
https://bugs.webkit.org/show_bug.cgi?id=227988
https://www.openwall.com/lists/oss-security/2021/10/27/4

Search for package or bug name: Reporting problems