CVE-2021-3114

NameCVE-2021-3114
DescriptionIn Go before 1.14.14 and 1.15.x before 1.15.7, crypto/elliptic/p224.go can generate incorrect outputs, related to an underflow of the lowest limb during the final complete reduction in the P-224 field.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2591-1, DLA-2592-1, DSA-4848-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
golang-1.11 (PTS)buster, buster (security)1.11.6-1+deb10u4fixed
golang-1.15 (PTS)bullseye, sid1.15.9-6fixed
golang-1.7 (PTS)stretch1.7.4-2+deb9u1vulnerable
stretch (security)1.7.4-2+deb9u3fixed
golang-1.8 (PTS)stretch1.8.1-1+deb9u1vulnerable
stretch (security)1.8.1-1+deb9u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
golang-1.11sourcebuster1.11.6-1+deb10u4DSA-4848-1
golang-1.11source(unstable)(unfixed)
golang-1.15source(unstable)1.15.7-1
golang-1.7sourcestretch1.7.4-2+deb9u3DLA-2591-1
golang-1.7source(unstable)(unfixed)
golang-1.8sourcestretch1.8.1-1+deb9u3DLA-2592-1
golang-1.8source(unstable)(unfixed)

Notes

https://github.com/golang/go/issues/43786
https://github.com/golang/go/commit/d95ca9138026cbe40e0857d76a81a16d03230871 (master)
https://github.com/golang/go/commit/5c8fd727c41e31273923c32b33d4f25855f4e123 (1.15.7)

Search for package or bug name: Reporting problems