CVE-2021-31215

NameCVE-2021-31215
DescriptionSchedMD Slurm before 20.02.7 and 20.03.x through 20.11.x before 20.11.7 allows remote code execution as SlurmUser because use of a PrologSlurmctld or EpilogSlurmctld script leads to environment mishandling.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2886-1
Debian Bugs988439

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
slurm-llnl (PTS)buster, buster (security)18.08.5.2-1+deb10u2vulnerable
slurm-wlm (PTS)bullseye (security), bullseye20.11.7+really20.11.4-2+deb11u1fixed
bookworm, bookworm (security)22.05.8-4+deb12u2fixed
trixie23.11.4-2fixed
sid23.11.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
slurm-llnlsourcestretch16.05.9-1+deb9u5DLA-2886-1
slurm-llnlsource(unstable)(unfixed)
slurm-wlmsource(unstable)20.11.7+really20.11.4-2988439

Notes

[buster] - slurm-llnl <no-dsa> (Minor issue)
https://github.com/SchedMD/slurm/commit/a9e9e2fedbd200ca545ab67dd753bd52c919f236 (2.11.7)
Initially already fixed in 20.11.7-1 (the tracker would do the right thing)
but the unstable upload invalidated the changelog 20.11.7-1 so use 20.11.7+really20.11.4-2
for consistency with BTS.

Search for package or bug name: Reporting problems