CVE-2021-3127

NameCVE-2021-3127
DescriptionNATS Server 2.x before 2.2.0 and JWT library before 2.0.1 have Incorrect Access Control because Import Token bindings are mishandled.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
golang-github-nats-io-jwt (PTS)buster0.0~git20181120.285cf2c-4vulnerable
bookworm, sid2.2.1~git20220330.442af02-1fixed
nats-server (PTS)bookworm, sid2.8.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
golang-github-nats-io-jwtsource(unstable)2.2.0-1
nats-serversource(unstable)(not affected)

Notes

- nats-server <not-affected> (Fixed before initial upload to Debian)
https://advisories.nats.io/CVE/CVE-2021-3127.txt
https://github.com/nats-io/jwt/security/advisories/GHSA-62mh-w5cv-p88c
https://github.com/nats-io/jwt/pull/149

Search for package or bug name: Reporting problems