CVE-2021-3200

NameCVE-2021-3200
DescriptionBuffer overflow vulnerability in libsolv 2020-12-13 via the Solver * testcase_read(Pool *pool, FILE *fp, const char *testcase, Queue *job, char **resultp, int *resultflagsp function at src/testcase.c: line 2334, which could cause a denial of service
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libsolv (PTS)stretch0.6.24-1+deb9u2vulnerable
buster0.6.35-2+deb10u1vulnerable
bullseye0.7.17-1vulnerable
bookworm, sid0.7.17-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsolvsource(unstable)(unfixed)unimportant

Notes

https://github.com/openSUSE/libsolv/issues/416
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems