Information on source package libsolv

Available versions

ReleaseVersion
stretch0.6.24-1+deb9u2
buster0.6.35-2+deb10u1
bullseye0.7.17-1
bookworm0.7.17-2
sid0.7.17-2

Open issues

BugstretchbusterbullseyebookwormsidDescription
CVE-2021-33938vulnerablevulnerablefixedfixedfixedBuffer overflow vulnerability in function prune_to_recommended in src/ ...
CVE-2021-33930vulnerablevulnerablefixedfixedfixedBuffer overflow vulnerability in function pool_installable_whatprovide ...
CVE-2021-33929vulnerablevulnerablefixedfixedfixedBuffer overflow vulnerability in function pool_disabled_solvable in sr ...
CVE-2021-33928vulnerablevulnerablefixedfixedfixedBuffer overflow vulnerability in function pool_installable in src/repo ...
CVE-2018-20533vulnerable (no DSA, ignored)vulnerable (no DSA, ignored)fixedfixedfixedThere is a NULL pointer dereference at ext/testcase.c (function testca ...
CVE-2018-20532vulnerable (no DSA, ignored)vulnerable (no DSA, ignored)fixedfixedfixedThere is a NULL pointer dereference at ext/testcase.c (function testca ...

Open unimportant issues

BugstretchbusterbullseyebookwormsidDescription
CVE-2021-3200vulnerablevulnerablevulnerablevulnerablevulnerableBuffer overflow vulnerability in libsolv 2020-12-13 via the Solver * t ...
CVE-2018-20534vulnerablevulnerablefixedfixedfixed** DISPUTED ** There is an illegal address access at ext/testcase.c in ...

Resolved issues

BugDescription
CVE-2019-20387repodata_schema2id in repodata.c in libsolv before 0.7.6 has a heap-ba ...

Security announcements

DSA / DLADescription
DLA-2088-1libsolv - security update

Search for package or bug name: Reporting problems