CVE-2021-32273

NameCVE-2021-32273
DescriptionAn issue was discovered in faad2 through 2.10.0. A stack-buffer-overflow exists in the function ftypin located in mp4read.c. It allows an attacker to cause Code Execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
faad2 (PTS)stretch (security), stretch2.8.0~cvs20161113-1+deb9u2vulnerable
buster2.8.8-3vulnerable
bookworm, bullseye, sid2.10.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
faad2source(unstable)2.10.0-1

Notes

https://github.com/knik0/faad2/issues/56
https://github.com/knik0/faad2/commit/1073aeef823cafd844704389e9a497c257768e2f (2_10_0)

Search for package or bug name: Reporting problems