CVE-2021-32278

NameCVE-2021-32278
DescriptionAn issue was discovered in faad2 through 2.10.0. A heap-buffer-overflow exists in the function lt_prediction located in lt_predict.c. It allows an attacker to cause code Execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2792-1, DSA-5109-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
faad2 (PTS)stretch2.8.0~cvs20161113-1+deb9u2vulnerable
stretch (security)2.8.0~cvs20161113-1+deb9u3fixed
buster2.8.8-3vulnerable
buster (security)2.10.0-1~deb10u1fixed
bullseye2.10.0-1fixed
bookworm, sid2.10.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
faad2sourcestretch2.8.0~cvs20161113-1+deb9u3DLA-2792-1
faad2sourcebuster2.10.0-1~deb10u1DSA-5109-1
faad2source(unstable)2.10.0-1

Notes

https://github.com/knik0/faad2/issues/62
https://github.com/knik0/faad2/commit/e19a5e491354e0e4664d02b796dacee28fb2521e (2_10_0)

Search for package or bug name: Reporting problems