CVE-2021-32919

NameCVE-2021-32919
DescriptionAn issue was discovered in Prosody before 0.11.9. The undocumented dialback_without_dialback option in mod_dialback enables an experimental feature for server-to-server authentication. It does not correctly authenticate remote server certificates, allowing a remote server to impersonate another server (when this option is enabled).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4916-1
NVD severitymedium
Debian Bugs988668

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
prosody (PTS)stretch0.9.12-2+deb9u2fixed
stretch (security)0.9.12-2+deb9u4fixed
buster, buster (security)0.11.2-1+deb10u2fixed
bullseye, sid0.11.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
prosodysourcestretch(not affected)
prosodysourcebuster0.11.2-1+deb10u1DSA-4916-1
prosodysource(unstable)0.11.9-1988668

Notes

[stretch] - prosody <not-affected> (Vulnerable code (=dwd) introduced later)
https://www.openwall.com/lists/oss-security/2021/05/13/1
https://prosody.im/security/advisory_20210512.txt
https://hg.prosody.im/trunk/rev/6be890ca492e
https://hg.prosody.im/trunk/rev/d0e9ffccdef9

Search for package or bug name: Reporting problems