CVE-2021-32920

NameCVE-2021-32920
DescriptionProsody before 0.11.9 allows Uncontrolled CPU Consumption via a flood of SSL/TLS renegotiation requests.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4916-1
NVD severityhigh
Debian Bugs988668

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
prosody (PTS)stretch0.9.12-2+deb9u2vulnerable
stretch (security)0.9.12-2+deb9u4vulnerable
buster, buster (security)0.11.2-1+deb10u2fixed
bullseye, sid0.11.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
prosodysourcebuster0.11.2-1+deb10u1DSA-4916-1
prosodysource(unstable)0.11.9-1988668

Notes

[stretch] - prosody <ignored> (Fix is consisting of many patches. Not appliable. Ingored)
https://www.openwall.com/lists/oss-security/2021/05/13/1
https://prosody.im/security/advisory_20210512.txt
https://hg.prosody.im/trunk/rev/55ef50d6cf65
https://hg.prosody.im/trunk/rev/5a484bd050a7
https://hg.prosody.im/trunk/rev/aaf9c6b6d18d

Search for package or bug name: Reporting problems