CVE-2021-33516

NameCVE-2021-33516
DescriptionAn issue was discovered in GUPnP before 1.0.7 and 1.1.x and 1.2.x before 1.2.5. It allows DNS rebinding. A remote web server can exploit this vulnerability to trick a victim's browser into triggering actions against local UPnP services implemented using this library. Depending on the affected service, this could be used for data exfiltration, data tempering, etc.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs989098

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gupnp (PTS)stretch1.0.1-1vulnerable
stretch (security)1.0.1-1+deb9u1vulnerable
buster1.0.5-0+deb10u1vulnerable
bookworm, bullseye, sid1.2.4-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gupnpsourceexperimental1.2.7-1
gupnpsource(unstable)(unfixed)989098

Notes

[bullseye] - gupnp <no-dsa> (Minor issue)
[buster] - gupnp <no-dsa> (Minor issue)
[stretch] - gupnp <no-dsa> (Minor issue)
https://discourse.gnome.org/t/security-relevant-releases-for-gupnp-issue-cve-2021-33516/6536
https://gitlab.gnome.org/GNOME/gupnp/-/issues/24
https://gitlab.gnome.org/GNOME/gupnp/-/commit/05e964d48322ff23a65c6026d656e4494ace6ff9 (gupnp-1.0)
https://gitlab.gnome.org/GNOME/gupnp/-/commit/ca6ec9dcb26fd7a2a630eb6a68118659b589afac (master)

Search for package or bug name: Reporting problems