CVE-2021-33829

NameCVE-2021-33829
DescriptionA cross-site scripting (XSS) vulnerability in the HTML Data Processor in CKEditor 4 4.14.0 through 4.16.x before 4.16.1 allows remote attackers to inject executable JavaScript code through a crafted comment because --!> is mishandled.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2813-1
Debian Bugs1015217

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ckeditor (PTS)buster4.11.1+dfsg-1vulnerable
bullseye4.16.0+dfsg-2fixed
bookworm, sid4.19.1+dfsg-1fixed
ckeditor3 (PTS)buster3.6.6.1+dfsg-3vulnerable
bookworm, sid, bullseye3.6.6.1+dfsg-7vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ckeditorsourcestretch4.5.7+dfsg-2+deb9u1DLA-2813-1
ckeditorsource(unstable)4.16.0+dfsg-2
ckeditor3sourcestretch(unfixed)end-of-life
ckeditor3source(unstable)(unfixed)1015217

Notes

[buster] - ckeditor <no-dsa> (Minor issue)
[stretch] - ckeditor3 <end-of-life> (EOL'd for stretch)
https://ckeditor.com/blog/ckeditor-4.16.1-with-accessibility-enhancements/#improvements-for-comments-in-html-parser
https://github.com/ckeditor/ckeditor4/commit/3e426ce34f7fc7bf784624358831ef9e189bb6ed

Search for package or bug name: Reporting problems