CVE-2021-33930

NameCVE-2021-33930
DescriptionBuffer overflow vulnerability in function pool_installable_whatprovides in src/repo.h in libsolv before 0.7.17 allows attackers to cause a Denial of Service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libsolv (PTS)stretch0.6.24-1+deb9u2vulnerable
buster0.6.35-2+deb10u1vulnerable
bullseye0.7.17-1fixed
bookworm, sid0.7.17-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsolvsource(unstable)0.7.17-1

Notes

[buster] - libsolv <no-dsa> (Minor issue)
https://github.com/openSUSE/libsolv/issues/417
https://github.com/openSUSE/libsolv/commit/0077ef29eb46d2e1df2f230fc95a1d9748d49dec (0.7.17)

Search for package or bug name: Reporting problems