CVE-2021-34428

NameCVE-2021-34428
DescriptionFor Eclipse Jetty versions <= 9.4.40, <= 10.0.2, <= 11.0.2, if an exception is thrown from the SessionListener#sessionDestroyed() method, then the session ID is not invalidated in the session ID manager. On deployments with clustered sessions and multiple contexts this can result in a session not being invalidated. This can result in an application used on a shared computer being left logged in.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow
Debian Bugs990578

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jetty9 (PTS)stretch9.2.21-1+deb9u1fixed
stretch (security)9.2.30-0+deb9u2fixed
buster9.4.15-1vulnerable
bullseye, sid9.4.39-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jettysource(unstable)(unfixed)
jetty8source(unstable)(unfixed)
jetty9sourcestretch(not affected)
jetty9source(unstable)9.4.39-2990578

Notes

[stretch] - jetty9 <not-affected> (vulnerable code is not present)
https://github.com/eclipse/jetty.project/security/advisories/GHSA-m6cp-vxjx-65j6
https://github.com/eclipse/jetty.project/issues/6277

Search for package or bug name: Reporting problems