CVE-2021-3498

NameCVE-2021-3498
DescriptionGStreamer before 1.18.4 might cause heap corruption when parsing certain malformed Matroska files.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4900-1
NVD severitymedium
Debian Bugs986911

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gst-plugins-good1.0 (PTS)stretch1.10.4-1fixed
stretch (security)1.10.4-1+deb9u1fixed
buster1.14.4-1vulnerable
buster (security)1.14.4-1+deb10u1fixed
bullseye, sid1.18.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gst-plugins-good1.0sourceexperimental1.18.4-1
gst-plugins-good1.0sourcestretch(not affected)
gst-plugins-good1.0sourcebuster1.14.4-1+deb10u1DSA-4900-1
gst-plugins-good1.0source(unstable)1.18.4-2986911

Notes

[stretch] - gst-plugins-good1.0 <not-affected> (Vulnerable code introduced later)
https://gstreamer.freedesktop.org/security/sa-2021-0003.html
https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/-/commit/02174790726dd20a5c73ce2002189bf240ad4fe0
Introduced by: https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/-/commit/f279bc5336dda19741a5996a108da42dd3201366

Search for package or bug name: Reporting problems