CVE-2021-3515

NameCVE-2021-3515
DescriptionA shell injection flaw was found in pglogical in versions before 2.3.4 and before 3.6.26. An attacker with CREATEDB privileges on a PostgreSQL server can craft a database name that allows execution of shell commands as the postgresql user when calling pglogical.create_subscription().
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs988735

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pglogical (PTS)buster2.2.1-4vulnerable
bullseye, sid2.3.3-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pglogicalsource(unstable)2.3.3-3988735

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=1954112
https://github.com/2ndQuadrant/pglogical/commit/95c0e8981485e09efab6821cf55a4e27b086efe5

Search for package or bug name: Reporting problems