CVE-2021-3522

NameCVE-2021-3522
DescriptionGStreamer before 1.18.4 may perform an out-of-bounds read when handling certain ID3v2 tags.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2641-1, DSA-4903-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gst-plugins-base1.0 (PTS)buster1.14.4-2+deb10u1fixed
buster (security)1.14.4-2+deb10u2fixed
bullseye (security), bullseye1.18.4-2+deb11u1fixed
bookworm, bookworm (security)1.22.0-3+deb12u1fixed
sid, trixie1.22.10-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gst-plugins-base1.0sourcestretch1.10.4-1+deb9u2DLA-2641-1
gst-plugins-base1.0sourcebuster1.14.4-2+deb10u1DSA-4903-1
gst-plugins-base1.0source(unstable)1.18.4-2

Notes

https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/-/issues/876
https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/-/commit/f4a1428a6997658625d529b9db60fde812fbf1ee (master)
https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/-/commit/8a88e5c1db05ebadfd4569955f6f47c23cdca3c4 (1.18.4)
https://gstreamer.freedesktop.org/security/sa-2021-0001.html

Search for package or bug name: Reporting problems