CVE-2021-35452

NameCVE-2021-35452
DescriptionAn Incorrect Access Control vulnerability exists in libde265 v1.0.8 due to a SEGV in slice.cc.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3240-1
Debian Bugs1014977

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libde265 (PTS)buster1.0.3-1vulnerable
buster (security)1.0.3-1+deb10u3fixed
bullseye1.0.8-1vulnerable
bookworm, sid1.0.11-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libde265sourcebuster1.0.3-1+deb10u1DLA-3240-1
libde265source(unstable)1.0.8-1.11014977

Notes

[bullseye] - libde265 <no-dsa> (Minor issue)
[stretch] - libde265 <postponed> (Minor issue, revisit when fixed upstream)
https://github.com/strukturag/libde265/issues/298
https://github.com/strukturag/libde265/commit/e83f3798dd904aa579425c53020c67e03735138d

Search for package or bug name: Reporting problems