DescriptionPostSRSd before 1.11 allows a denial of service (subprocess hang) if Postfix sends certain long data fields such as multiple concatenated email addresses. NOTE: the PostSRSd maintainer acknowledges "theoretically, this error should never occur ... I'm not sure if there's a reliable way to trigger this condition by an external attacker, but it is a security bug in PostSRSd nevertheless."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs990439

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
postsrsd (PTS)stretch1.4-1vulnerable
stretch (security)1.4-1+deb9u1vulnerable
bookworm, sid, bullseye1.10-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[buster] - postsrsd <no-dsa> (Minor issue; can be fixed via point release)
[stretch] - postsrsd <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems