CVE-2021-3570

NameCVE-2021-3570
DescriptionA flaw was found in the ptp4l program of the linuxptp package. A missing length check when forwarding a PTP message between ports allows a remote attacker to cause an information leak, crash, or potentially remote code execution. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. This flaw affects linuxptp versions before 3.1.1, before 2.0.1, before 1.9.3, before 1.8.1, before 1.7.1, before 1.6.1 and before 1.5.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4938-1
NVD severityhigh
Debian Bugs990748

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linuxptp (PTS)stretch1.8-1vulnerable
buster1.9.2-1vulnerable
buster (security)1.9.2-1+deb10u1fixed
bullseye, sid3.1-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxptpsourcebuster1.9.2-1+deb10u1DSA-4938-1
linuxptpsource(unstable)3.1-2.1990748

Notes

https://github.com/richardcochran/linuxptp/commit/a1e63aa3a7304647913707c4df01f3df430806ab (master)
https://github.com/richardcochran/linuxptp/commit/ce15e4de5926724557e8642ec762a210632f15ca (v3.1.1)
https://github.com/richardcochran/linuxptp/commit/c15da0756d9b0ad9c0b9307c4a8685b490b76485 (v1.9.3)
https://github.com/richardcochran/linuxptp/commit/7795df89dd4f94e0f55959dc61a85535d0f01cae (v1.8.1)
https://www.openwall.com/lists/oss-security/2021/07/06/1

Search for package or bug name: Reporting problems