CVE-2021-36373

NameCVE-2021-36373
DescriptionWhen reading a specially crafted TAR archive an Apache Ant build can be made to allocate large amounts of memory that finally leads to an out of memory error, even for small inputs. This can be used to disrupt builds using Apache Ant. Apache Ant prior to 1.9.16 and 1.10.11 were affected.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ant (PTS)stretch (security), stretch1.9.9-1+deb9u1vulnerable
buster1.10.5-2vulnerable
bullseye, sid1.10.9-4vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
antsource(unstable)(unfixed)unimportant

Notes

https://www.openwall.com/lists/oss-security/2021/07/13/5
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems