CVE-2021-36411

NameCVE-2021-36411
DescriptionAn issue has been found in libde265 v1.0.8 due to incorrect access control. A SEGV caused by a READ memory access in function derive_boundaryStrength of deblock.cc has occurred. The vulnerability causes a segmentation fault and application crash, which leads to remote denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libde265 (PTS)stretch1.0.2-2vulnerable
buster1.0.3-1vulnerable
bookworm, sid, bullseye1.0.8-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libde265source(unstable)(unfixed)

Notes

[bullseye] - libde265 <no-dsa> (Minor issue)
[buster] - libde265 <no-dsa> (Minor issue)
[stretch] - libde265 <no-dsa> (Minor issue)
https://github.com/strukturag/libde265/issues/302

Search for package or bug name: Reporting problems