NameCVE-2021-36770, as distributed in Perl through 5.34.0, allows local users to gain privileges via a Trojan horse Encode::ConfigLocal library (in the current working directory) that preempts dynamic module loading. Exploitation requires an unusual configuration, and certain 2021 versions of (3.05 through 3.11). This issue occurs because the || operator evaluates @INC in a scalar context, and thus @INC has only an integer value.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libencode-perl (PTS)buster3.00-1+deb10u1fixed
bullseye (security)3.08-1+deb11u1fixed
bookworm, sid3.19-1fixed
perl (PTS)buster5.28.1-6+deb10u1fixed
bullseye (security)5.32.1-4+deb11u1fixed
bookworm, sid5.36.0-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libencode-perlsourcestretch(not affected)
libencode-perlsourcebuster(not affected)
perlsourcestretch(not affected)
perlsourcebuster(not affected)


[buster] - libencode-perl <not-affected> (Vulnerable code introduced later)
[stretch] - libencode-perl <not-affected> (Vulnerable code introduced later)
[buster] - perl <not-affected> (Vulnerable code introduced later)
[stretch] - perl <not-affected> (Vulnerable code introduced later)
Introduced by: (3.05)
Fixed by: (3.12)
Introduced by: (v5.32.0-RC0)
Fixed by:

Search for package or bug name: Reporting problems