CVE-2021-38425

NameCVE-2021-38425
DescriptioneProsima Fast DDS versions prior to 2.4.0 (#2269) are susceptible to exploitation when an attacker sends a specially crafted packet to flood a target device with unwanted traffic, which may result in a denial-of-service condition and information exposure.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
fastdds (PTS)bullseye2.1.0+ds-9vulnerable
bookworm, sid2.6.0+ds-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
fastddssource(unstable)(unfixed)

Notes

[bullseye] - fastdds <no-dsa> (Minor issue)
https://github.com/eProsima/Fast-DDS/issues/2267
https://github.com/eProsima/Fast-DDS/pull/2269
https://www.cisa.gov/uscert/ics/advisories/icsa-21-315-02

Search for package or bug name: Reporting problems