CVE-2021-38443

NameCVE-2021-38443
DescriptionEclipse CycloneDDS versions prior to 0.8.0 improperly handle invalid structures, which may allow an attacker to write arbitrary values in the XML parser.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cyclonedds (PTS)bullseye0.7.0-7vulnerable
bookworm, sid0.10.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cycloneddssource(unstable)0.8.1-2

Notes

[bullseye] - cyclonedds <no-dsa> (Minor issue)
No mention of CVE upstream
https://projects.eclipse.org/projects/iot.cyclonedds
https://www.cisa.gov/uscert/ics/advisories/icsa-21-315-02

Search for package or bug name: Reporting problems